The purpose of this document is to provide instructions on converting the Ham Radio Deluxe logbook from the MS Access Database to the Maria Database, which is a variant of the MySQL database.
This is primarily for those who have a large number of contacts logged in their logbook and are having problems with slow logbook function speeds. The SQL database is more reliable, can be easily networked so that one logbook can be accessed by multiple computers at the same time and the database is much, much faster than the MS Access DB.


Two programs are needed to make the change from the Access DB to the MariaDB. The first being the Maria database installation software. You can download the MariaDB installation file from the https://mariadb.org/ website. The MariaDB can be either the 32-bit or the 64-bit version, depending on which Windows version you’re using.

The second program you will need is the 8.0 or newer ODBC Connector which can be downloaded from https://dev.mysql.com/downloads/connector/odbc/ 


One very important note. Regardless of whether your Windows OS is 32 or 64-bit, you need to make certain you download ONLY the 32-bit ODBC connector.

Once you have the MariaDB software and the ODBC connector, you can proceed with the following instructions.


Backup Your HRD Logbook

By default, your HRD logbook is backed up in the following folder:

C:\Users\<Your Name>\AppData\Roaming\HRDLLC\HRD Logbook 


If you can’t locate the above folder it’s because it is normally hidden to prevent accidentally updating or deleting the HRDLLC folder and losing user configured options. To locate this folder, open your Windows Control Panel, Locate and open the “File Folder options” app. On the top of this window select the “View” tab. On the “View” tab, select “Show hidden files, folders and Drives” and close the window.

Now, navigate to C:\Users\<Your Name>\AppData\Roaming\HRDLLC\HRD Logbook and look for files that have the “XML” extension. If you have not changed the location or filename of your backup files, you will look for a file called “My Logbook backup 2020-03-06 1115.xml” where the “2020-03-06 1115.” portion of the filename is the most recent date and time of the backup. I suggest highlighting this backup file and copy/paste it to your desktop so you know exactly where it is when you’re ready to restore the file to your Maria Database.

For more information about backing up and restoring your logbook database, please see the video on our YouTube channel at  https://youtu.be/Py4vvj1bRZk or visit our Wiki (Online Manual) at https://wiki.HamRadioDeluxe.com/index.php/Logbook#Backups


Once you have a current backup of your logbook, it’s time to install the Maria DB on your computer.

 

Installing The MariaDB Software

If you have not yet done so, go to the MariaDB website at https://mariadb.org/ and download the most recent version of the MariaDB software. You can use either the 32-bit or 64-bit version depending on if you are running a 32 or 64-bit version of Windows. Once you have the MariaDB software, execute the installation file and follow the onscreen prompts to install.


Figure #1

MariaDB splash screen will be the first screen you see. Click on [Next] to continue

 

Figure #2

Accept the MariaDB license agreement and click [Next]

 

 

 

 

 

Figure #3

Just click the [Next] button

 

Figure #4

In the above screen, enter and confirm a password that will be easy for you to remember. Be sure to write it down and keep it in a safe place in the event you forget it. Be sure you have checked all 3 check boxes shown on this screen.

 

 

  

 

The next steps install the MariaDB services



Figure #5

On the above page, you can leave everything set to default.

 

Figure #6

Hit the [Next] button to continue

 

 

 

 

 

 

Figure #7

You’re now going to install the database. Click [Install]

 

Figure #8

Click [Yes]

 

Figure 9

Click the [Finish] button to complete the installation

 

Installing the ODBC Connector

At this point, we’re ready to install the ODBC Connector. Go to your Download folder or the folder where you saved your downloads and locate and run the “mysql-connector-odbc-8.0.18-win32.exe” installation file.

Figure #1

Click on the [Next] button

 

 

 

Figure #2

Accept the license agreement and click [Next]

 

Figure #3

Select the “Typical” setup and click [Next]

 

 

  

Figure #4

Click [Next] to install the ODBC connector

 

Figure #5

Click [Yes] to complete the ODBC Connector installation

  

  

Figure #6

Click [Finish] when the installation is completed

 

Configuring the HRD Logbook

Now that we have the Database server installed and the ODBC connector ready, we can now configure the Logbook in the HRD Logbook software, so, let’s open the HRD Logbook.

HRD #1

In the HRD Logbook top menu, select “Tools > Configure > Logbook > Databases”

HRD #2

At this point you will add your MariaDB Logbook to the databases in HRD.

 

HRD #3

Select the ODBC Administrator

 

HRD #4

Click on the [Add] button

 

HRD #5

Click on the “MySQL ODBC 8.0 Unicode Driver” and click [Finish]. The purpose of using the Unicode driver is so your logbook will interpret foreign language characters from Callsign Lookup options properly. 

 



HRD #6

In the “Data Source Name” box enter a name of your choice and in the “Description” box enter the description of your database. Make sure TCP/IP Servers is checked and “127.0.0.1” is in this field. Make sure the “Port” field is set to default. Set the User to “root” and enter your root “password”. #1> select your SQL option and click the [Test] button.

 

HRD #7

If your “TEST” from the previous step says the connection is correct, click the [OK] button

 

HRD #8

Your SQL database “Name” “Platform” and “Driver” will now show in the ODBC Data Source Administrator. Click the [OK] button to return to your HRD Logbook Database window.

 

 

 

 

HRD #9

Click the [Add] button

 

HRD #10

Enter the “Title”. The Title is what you want to call the Logbook. Enter the “Description” such as “My Default Logbook” or what ever you would like to say about the log and move on to the next image. DO NOT click the OK button on this image. Look at the next image.

 

 

 

 

 

HRD #11

Now, click on the “Advanced Options”

 

HRD #12

In the “Or Select For Repair” dropdown, select the name of your Data Source and click the [OK] button to return to the Logbook Database Manager.

HRD #13

Right click on the name of the logbook you just created and click on the “Set As Default”.

 

HRD #14

Select both of the “Listen For…” options as shown above.

 

 

HRD #15

Click the [OK] button

 

 

  

 

 

HRD #16

Back in the Logbook display, click on the [Open] button on the toolbar and in the “Open” dialog, select your MySQL Logbook and click [OK] to open.

 

Restore Your Backup

Now that you have created your Maria MySQL database, it’s ready to have the contacts from your Access log added. This is a simple process of restoring the backup you made at the start of this process to the MySQL database.

Figure #1

On the logbook main menu, click on “Logbook > File > Backups > Restore”. This will open the Restore function.

 

 

Figure #2

Click on the navigation box as shown here.

 

Figure #3

When the navigation box opens, navigate to the folder where you saved the backup that you made when you started this process. In this case our backup is located on our desktop. Right-click on the backup file to highlight and click the [Open] button.

 

  

 

Figure #4

When the backup file has opened, click the [Restore] button to begin the restoration of your logbook.

 

Follow the on-screen prompts to restore all your contacts to the MySQL database.
When all the records have been restored you will receive a prompt to “Finish” the process.
When you click the Finish button, you will be returned to the Logbook screen and in a few seconds your contacts will now appear in your MySQL Database.


As always, we highly recommend you have ONLY ONE active database where you store ALL of your contacts.
The reason for this should be apparent. First and foremost is the HRD Awards Tracking only looks at your active logbook when it’s tracking your contacts and confirmations.

With multiple logbooks being on the computer, the Awards Tracking can’t accurately track the correct data. Also, having multiple logbooks creates longer search times when checking for the Worked Status for the WSIs in your DX Cluster. Also, when checking for previously worked stations when a call is added to your ALE screen, only the active database can be checked at the time the call is entered.

If you need to create additional database for an event like Field Day, or a Special Event, we recommend creating an Access database for those contacts. After the event is over, you can then export all the contacts from the event log and import them into your main logbook for uploading to LoTW or eQSL for their Awards, or uploading to QRZ Logbook, ClubLog or HRDLog.net.
Once the contacts are imported into your main database, the additional logbooks can be archived and kept off line and deleted from the Logbook program.