Start a new topic

Winkeyer no longer sending Macros

I've searched all over the HRD site and the Internet without luck so here goes.....


Background: Rig is Flex 6600M using SSDR v 3.1.8 and I've been faithfully using HRD v6.6.0.337 for over a year for CW, RTTY and PSK. Rig Control has never been needed with my setup so I simply have Slicemaster v0.10.7b (Flex third party software) launch DM780 and then I manually start HRD Logbook. All was working well until about a week or so ago.


Problem: The CW Macros are no longer sending to the Flex in the CW (WinKey) mode. I get a "Winkeyer is not started" error message. 


Analysis/Actions: In checking Winkeyer's dialog box, it shows "Connected".  If push the Winkeyer dialog box's "test" button it transmits the canned "test de DM" to the Flex. If I change the DM-780 CW mode to "KY CMD", the Macros keys the Flex perfectly so I know the Winkeyer's Flex COM Port (COM7) is working. RTTY and PSK Macros also key the Flex normally. WSJT also works perfectly (outside of HRD).


Thinking it may have been corrupted software, I upgraded to the current HRD v6.7.0.301 and get the identical results. I've checked all my HRD and Flex Winkeyer settings (serial port COM7) and everything is as it was a year ago when I last upgraded HRD software. The only difference is that the Flex CAT Control Panel's CAT port COM5 is now showing the "Process" as "OmniRig" instead of the former "None" but Flex doesn't give the option of changing it back. Since the PC is controlling the transceiver nicely  (except for Winkeyer), I don't think this is a rabbit hole worth going under.


Before opening up a Support Ticket,  I thought one of the "Community" might offer some suggestions. Having recently been "bit" by a Windows upgrade that prevented HRD Logbook from starting (BTW, thanks to HRD for writing that timely solution email!), this is smelling of the same or possibly a "cockpit error".


Thanks in advance,


Mike WB6UTW


Have you tried using Rig Control instead of Slicemaster?

I don't know that software.

I’ve had similar issues with my WinKeyer sense I updated to the latest version of HRD.  The WinKeyer box shows connected and transmits CW on test but their is a pop up that says WinKeyer not connected.  The water fall doesn’t work the same as before the update. I went as far as to remove the full HRD software and reboot then reinstall it with the same results.  I keep starting tickets with no help. 


1 person likes this

I  Meant  WinKeyer not started not connected.  


1 person likes this

Dan,

I'm really happy you replied. Nice to know I'm not alone. Since this "came out the blue" first with my trusty 2019 v6.6 HRD software (and repeated identically with the new 2020 v6.7 software), I have to conclude this has nothing to do with the new HRD software build. Again, I'm suspecting something to do with a recent Windows 10 update. I might post this on the Facebook HRD User Group for comment. I'm discovering that more people (especially the companies' management) tend to read and respond to FB posts than their older site-dedicated Forums. 

John,

Thanks for your earlier reply. Tim Browning and I went down the Rig Control path about two years ago without success just after I bought the Flex. We both concluded that Rig Control generally conflicted with the Flex SmartSDR software as it performed many of the same functions. 73

I think you correct. They seem to rely on social media more than user direct input.  FYI I got tired of windows 10 issues being blamed on HRD not working so I put my Alex based operating system in another computer to the test. I am having the same results and same issues with CWWinkeyer etc.  I also have a laptop with Windows 7 and not updated and the issues are not their.  This laptop has not been on the internet for three years in a drawer and was used for field day only with no internet. All files were uploaded with another computer after field day. My club had 9 laptops used this way.

Dan,

I forgot to ask....

1) What radio are you using? 

2) Is your HRD's Rig Control launched?

3) Just before upgrading to the new HRD v6.7 software, did you happen to try running Winkeyer on the older v6.6 software and did it work properly?


I just posted a shorter version to Facebook's HRD Fan Group and will report back anything I receive


73, Mike   

1. I’m using a Yaesu FT-897D.

2. Yes HRD Rigcontrol works fine with WJTS on FT-8 with no issues.

3. My WinKeyer worked on all the last two past versions.

FYI I have a laptop with Linux operating system that has the version on the CD from three years ago that doesn’t have these issues I took out for a test.  I haven’t used this laptop but last on field day three years ago with no internet connection.

FWIW. My IC7610 works flawlessly with Winkeyer in DM780.

1 person likes this

I can use FLDIGI and FLRIG with my WinKeyer and it works with no issues on my Yeasu FT-897D. I just want to be able to use HRD the same way.

What really bothers me is now after the latest update I did last week every time I start DM-780 and  Choose  WinKey a pop up box comes up with a statement “WinKeyer not started”. The WinKeyer box also pops up and says connected.  I click on test and my radio transmits the test CW.  But when I try to send a CW CQ nothing happens.  It shows the CQ micro and a line goes through each letter as if it’s sending the CQ but my radio doesn’t go into transmit nor does the WinKeyer do anything at all.  If I open up the WinKeyer box and click test again my radio transmits the test CW string. WHY?  

Going through every digital mode I have similar issues in different ways depending on the mode.  WHY?

I have everything under control?  I don’t think so.

What am I supposed to do?  Take apart the HRD DM-780 program apart line by line to find out why it’s not working?   Their are several hams on the IO web site with Kenwood, Icon, Yeasu, and several other brands of radios both newer and older than mine with the same issues.  
I’m retired and just want to put some time into my hobbies.  Not coding.  That’s why I purchased HRD instead of using freewhere.  

Dan Jenkins W8DEJ

Dan, I truly share your agony.
Have you raised a ticket for this issue?
Login or Signup to post a comment