Start a new topic

FT-450 won't kick into transmit mode/receive is fine

Got a new PC, HP-Envy, and downloaded latest version of HRD.  Rigblaster Advantage showed connected to Comm3.  The unit will receive perfectly, but will not transmit.  The screen is showing the macro being sent and the rigblaster appears to be receiving the data from PC.  I have not changed any cables, same CAT cable as before.  Have been using HRD off and on for 10 years.   Checked the firewall to allow HRD to pass.

Can't figure out what the blockage is.  Any help is appreciated. 

Charlie, WA1KCI


On the logbook page click to show Radio Pane and make sure you have a TX button showing. Also make sure your radio is in correct mode for what your trying to do many radios will not TX in CW except via key jack.

73 Morris WA4MIT

TX.JPG
(21 KB)

Thanks for the reply, Morris.  Yes, checked that and it looks good.  The odd thing is when I "transmit" a macro,

the Rigblaster Advantage lights up like it's going through the motions, but the FT-450 won't kick in.  I have everything the same as before when I used my old computer. Cat cable is the same, connections the same, etc.  

Hi Charlie you should be able to key radio with the TX button on radio pane also. Maybe something in your radio menus has changed I am not familiar with your radio or rigblaster so it hard to say much more. I would suggest looking in a 450 radio group and do a search for more help. If you find something post it here for others to see. It seems the old postings did not make it into this new forum. Wish you luck 

73 Morris WA4MIT

Thanks Morris.  In investigating everything from the FT-450 menu, through changing the comm port, I think the issue lies with a conflict between the built in speaker device and the Rigblaster's Mic and Speaker.  In Device Manager both units are listed under audio devices, but it's hard to tell if Windows 10 knows they are different.  In my old PC, I never used the speakers, or audio, so I might have disabled them, hard to remember as I had HRD set up for years on it.  But it seems that may be it.  I do not want to disable the speakers as I now use this PC for Zoom video calls.  I will just have to operate it differently, maybe without CAT control (never tried it that way.

73 and good DX, it looks like PSK31 is getting busier,

Charlie, WA1KCI

Hi Charlie so you were using audio & vox keying is that right?. Then you would have had to use the speaker or line out to feed audio to rigblaster or mic conn. to key radio. I looked at manual for FT450 and on pages 72 ,3 & 4 there are setups for DIGI modes with hard keying via a rear connector. But either way you still have to feed audio into radio to have tones out. Lots of ops add a second soundcard for ham radio use only this way you can have your computer sound separate from radio other wise if your in TX and something in computer sounds off that goes out over the air. Sometimes when listening you can tell this happening game sounds and other such is transmitted. 

I would think your rigblaster would have provisions for a keying line output you just need a connector to match what is on rear of radio.  I added a dual serial connector card to my computer use one for FT1000mp and other for CW keying. Add in cards are cheap on ebay if you have slots for them. I hope you get things going. I do a lot of FT8 & FT4 operations these days PSK is difficult to use with these poor band conditions.

73 Take care Morris WA4MIT

Hi Morris,

There is a CAT serial cable between the rigblaster and FT-450.  The rigblaster is connected to the PC via a USB cable.  When I try to TX on HRD, the three lights blink on the rigblaster telling me it is getting the audio from the PC.  That is the way it's always been.  I will check out those pages in the manual.  I have heard about a separate card,  and if nothing else works, I will go that way.  That makes sense using the separate card, as it avoids any conflict with the  PC audio.  Good ideas, thanks very much.  

73, Charlie WA1KCI

Charles, 

The Rigblaster is an external sound card. How is the Rigblaster connected to the radio? Is it thru the microphone connector only? Does the transmit light on the Rigblaster stay on when you transmit?

You said this is a new computer with a new HRD installation so I suspect you have something configured incorrectly in the HRD suite. Do you still have the old computer? Can you compare the old computer HRD settings to the new HRD installation.


Here are a couple of articles on setting up HRD for use with the Rigblaster. It's for an older version of HRD and a different radio but should lead you in the right direction. 

http://www.westmountainradio.com/content.php?page=rb_radio_news&navcode=/newshd


http://www.westmountainradio.com/pdf/RB_Advantage_Software_Configuration.pdf


Hope this helps,

Charlie - KØLAF



Hi Charlie I looked up the rigblaster advantage and this unit has a built in sound card so you should not need a second card or serial port card the advantage has all you should need built into it and if you had it working it should work now. Reading the manual there is a 3 position switch for PTT control this should be in pos 1 for serial port keying which you said you have a DB9 cable from RB to radio. You might want to re-seat the serial cable make sure its plugged in good. Unless something has happened to radio or RB unit this thing should work.

73 Morris WA4MIT 

Hi Morris,

Well, the simplest solution was the answer.  With all my moving around the mic cable in the radio coming from the rigblaster wasn't fully seated.  You made me double check so thanks.  I am back on the air.

Now I just have to copy my log files to the new PC.  Hopefully, that won't take as long.

Thanks for your effort with me.  You the only one who responded, so I am doubly thankful for that.

Good DX and good health,

73, Charlie WA1KCI

Good Job Morris!


Charlie - KØLAF

Thank you K0LAF and the other Charlie WA1KCI. 

Charlie that is a good manual with good pictures and descriptions. You might want to check in device manager and make sure you computer soundcard is marked for default device if it is your in business. You should be able to use computer sounds without it going out over air. That is a good RB unit. Have fun with your digi modes hope to see you on the bands.

73 Morris WA4MIT

Login or Signup to post a comment