Start a new topic

HRD Stopped Connecting To My IC-7300

All of a sudden HRD stopped connecting to my IC-7300.  Nothing has changed with my PC.  Still using Windows 10.  It was all working just fine a couple of weeks ago and now it will not connect. 

I have verified all the settings, same Port as my Device Manager shows on PC and all other settings are set the way they were before it stopped working.

HRD Version 6.5.0.207

Any Ideaa?

K5EAG


2 people have this question

I have tried several different USB cables with and without ferrite coils and also tried 3 different computers and still all have the same issues.

I talked with HRD via their support email system and they informed me that since I no longer have a paid for active subscription for support, they are not able to help me.  However, if I upgrade and pay them $99 for a new subscription they will help me.  I understand that, however, before I pay out $99, I want to be sure it still works.  Strange that all of a sudden it just stopped working with no changes or updates at my end.


Hello Billie,


You were talking about the computer settings only. Did you check that the radio settings match those of the virtual COM Port of your computer? I had the problem that my radio switched unattendendly the baudrate from 19,200 to AUTO some time ago.


73

Wolf, DL6JZ

I would uninstall the driver download the latest install this then see what happens. It is possible that there is a problem in radio if you have a local ham that you could try your radio on his setup or his on yours or maybe you have another radio see if it works on your computer. Try to eliminate something.


73 Morris WA4MIT

My ICOM 7300 stopped working after several windows 10 major updates, and I have been through the setup page on HRD several times, tried several usb cables without and with ferrite cores with no success. Support gave me a link to the page I was using for setting up the 7300 so they were no help. I am going to try another computer next.

Have you tried another USB cable? with the radio only connected to cable can you see the radio port in device manager? 


73 Morris WA4MIT

I year renewal/support is only $49.95


https://www.hamradiodeluxe.com/buy/HRDPSL.html


73,

Charlie - KØLAF

I have a Yaesu FTDX1200 and I have exactly the same problem. Rig control working fine and then suddenly it stopped working . I have the latest release of HRD  and have checked my drivers and ports on pc and all seems fine. Perplexed!


Login or Signup to post a comment